Wednesday, January 19, 2011

IP Split-Horizon EIGRP

IP Split-Horizon EIGRP

Printer-Friendly Format

Command

IP Split-Horizon EIGRP
Use

Split Horizon protects against routing loops by not accepting routes on the same interface that a router sends updates out.
This normally has to be turned off in hub and spoke topologies to ensure full reachability.
Syntax

Router(config-router)#network
OR
Router(config-router)#network
Example




In this example we will configure EIGRP 100 on all routers in the in topology.

R1(config)#router eigrp 100
R1(config-router)#no auto
R1(config-router)#network 10.4.4.0 0.0.0.255
R1(config-router)#network 1.0.0.0

Notice that EIGRP also stripes the network statements back to its classful network boundary.

3(config)#router eigrp 100
R3(config-router)#no auto
R3(config-router)#network 3.0.0.0
R3(config-router)#network 10.4.4.0 0.0.0.255

If we configure the network statement with a wildcard, we can control what interfaces are put into EIGRP.

R4(config)#router eigrp 100
R4(config-router)#no auto
R4(config-router)#network 4.0.0.0
R4(config-router)#network 10.4.4.0 0.0.0.255

Checking the EIGRP routing tables we see that R1 and R3 have not received any routes.

R1(config-router)#do show ip route eigrp
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/2297856] via 10.4.4.4, 00:02:34, Serial1/0
R1(config-router)#

R3(config)#do show ip route eigrp
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/2297856] via 10.4.4.4, 00:02:54, Serial1/0
R3(config)#

R4(config-router)#do show ip route eigrp
1.0.0.0/32 is subnetted, 3 subnets
D 1.1.1.1 [90/2297856] via 10.4.4.1, 00:00:20, Serial0/0
D 1.3.3.3 [90/2297856] via 10.4.4.1, 00:00:20, Serial0/0
D 1.2.2.2 [90/2297856] via 10.4.4.1, 00:00:20, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2297856] via 10.4.4.3, 00:00:28, Serial0/0
R4(config-router)#


Now we will disable split-horizon on R4's frame-relay interface.
R4(config-router)#int s0/0
R4(config-if)#no ip split-horizon eigrp 100
R4(config-if)#
*Mar 1 00:14:05.915: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.4.4.1 (Serial0/0) is resync: split horizon changed
*Mar 1 00:14:05.919: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.4.4.3 (Serial0/0) is resync: split horizon changed
R4(config-if)#

Now we see all the routes on R1 and R3.
R1(config-router)#do show ip route eigrp
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2809856] via 10.4.4.4, 00:00:58, Serial1/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/2297856] via 10.4.4.4, 00:00:07, Serial1/0
R1(config-router)#

R3(config-router)#do show ip route eigrp
1.0.0.0/32 is subnetted, 3 subnets
D 1.1.1.1 [90/2809856] via 10.4.4.4, 00:01:23, Serial1/0
D 1.3.3.3 [90/2809856] via 10.4.4.4, 00:01:23, Serial1/0
D 1.2.2.2 [90/2809856] via 10.4.4.4, 00:01:23, Serial1/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/2297856] via 10.4.4.4, 00:00:32, Serial1/0
R3(config-router)#

show ip eigrp topology

show ip eigrp topology
Command
Show IP EIGRP Topology
Use
This command shows EIGRP topology information on the router. This information includes the advertised and feasible distance for all paths as well as the successors. This is especially useful when calculating variance.
Syntax
Router#show ip eigrp topology
Example

In the below example we see the EIGRP topology information on R2
R2(config)#do show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(2.2.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 1.1.1.1/32, 1 successors, FD is 156160
via 10.1.1.1 (156160/128256), FastEthernet0/0
P 3.3.3.3/32, 1 successors, FD is 156160
via 10.2.2.3 (156160/128256), FastEthernet1/0
P 2.2.2.2/32, 1 successors, FD is 128256
via Connected, Loopback0
P 1.3.3.3/32, 1 successors, FD is 156160
via 10.1.1.1 (156160/128256), FastEthernet0/0
P 1.2.2.2/32, 1 successors, FD is 156160
via 10.1.1.1 (156160/128256), FastEthernet0/0
P 10.1.1.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 10.4.4.0/24, 2 successors, FD is 2172416
via 10.1.1.1 (2172416/2169856), FastEthernet0/0
via 10.2.2.3 (2172416/2169856), FastEthernet1/0
P 10.2.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet1/0

Wednesday, January 12, 2011

Difference Between DSL and ADSL

Difference Between DSL and ADSL

DSL vs ADSL
DSL (Digital Subscriber Line) is the generic term for services that provide internet connections using digital data connections between a modem and a phone line. What’s great about DSL, is that even when the phone line is in use, there is no interruption, and you can still experience a high speed internet connection even when you are making calls. The only issue is, that when you are close to the central office of the company with which you are subscribed, you will have faster internet, but when you are far from their central office, although you are within their scope, you will have a slower internet connection.

There are different types of DSL. There’s SDSL, VDSL, and ADSL. ADSL stands for Asymmetric Digital Subscriber Line. This type of service means that the speed of data sent is known as upstream, and the data received is known as downstream, and the speeds are not always guaranteed to be the same. They have different speeds that change from time to time. The most requested service is the ADSL service. In regards to ADSL, the internet service providers offer options for higher bandwidth, in upstream, downstream or both. The only thing is, they naturally charge higher rates for higher speeds.

ADSL uses a special ADSL modem, and a micro-filter in the subscriber’s telephone line.

This is what allows the ADSL service and telephone service to be used at the same time. The word ‘asymmetric’ in ADSL actually means that the downstream is faster than the upstream. ADSL supports a downstream rate of 1.5 to 9 Mbps, and an upstream rate of 16 to 640 Kbps.

When you use ADSL, your PC will always be connected to the internet, as long as the power is on, and once you ‘turn on’ your computer, your PC will automatically have an internet connection, unless you manually disconnect. Unlike dial-ups, ADSL can serve various computers within a house for multiple members simultaneously.

Summary:

The simple difference between DSL and ADSL is that DSL is the generic term for Digital Subscriber Line services, and ADSL, or Asymmetric Digital Subscriber Line, is just one of its types. There are other types of DSL, such as SDSL and VDSL.



Difference Between PPPoE and PPPoA

Difference Between PPPoE and PPPoA

PPPoE vs PPPoA

Many internet users are often plagued with the decision of what kind of protocol to use with their connection. There are many questions, experimentation, and flip-flopping between PPPoE and PPPoA. Unfortunately, many of the confusions hover above these two protocols.

Both of these protocols give internet service providers (ISP) the capability to rollout broadband use. Using these protocols gives relative security as it obliges the end-user to verify or authenticate to a server before having network access.

PPPoE and PPPoA are mainly used with Digital Subscriber Line (DSL). Both protocols provide flexibility in billing which is very advantageous to providers. Moreover, the use of network resources can be monitored easily and along with this feature, troubleshooting and managing network usage is less problematic.

PPPoE is an abbreviation Point-to-Point Protocol over Ethernet and it is a kind of networking protocol that encapsulates PPP frames inside the Ethernet frames. Basically, PPPoE is configured as a point to point connection between two Ethernet ports.

This protocol is normally used in ISP’s lower packages as PPPoE is often utilized to function in lower bandwidth throughput rate. PPPoE is perhaps the most common protocol used when connecting to the internet.

Point-to-Point Protocol over ATM (PPPoA) is also a network protocol but this time, it is for encapsulating frames inside AAL5 or ATM Adaption Layer 5. ATM means Asynchronous Transfer Mode, a kind of switching using time division multiplexing in an asynchronous manner.

In the enterprise packages, PPPoA is typically the protocol of choice. It will require a Static IP configured straight into the hardware (modem). PPPoA is said to have less overheads compared to PPPoE therefore, the former is slightly faster than the latter. However, for the end-user, the difference in speed is almost negligible.

Modems that support PPPoA use Asynchronous Transfer Mode — which uses very small, fixed-length packets, in contrast to Ethernet, which uses relatively large, variable-length packets — to do whatever it needs to do.

Summary:

1. PPPoE means Point-to-Point Protocol over Ethernet while PPPoA means Point-to-Point Protocol over ATM.

2. PPPoE encapsulates PPP frames inside the Ethernet frames while PPPoA encapsulates frames inside AAAL5.

3. PPPoE is often used in lower packages while PPPoA is often used in enterprise packages.

4. PPPoE is more commonly used than PPPoA.

5. PPPoA has slightly less overhead than PPPoE therefore, it is a bit faster.



Thursday, August 19, 2010

Bundle ping to text file

c:\>ping 192.168.1.1 -t -l 10000>c:\bundle.txt

Mirror port with cisco switch

swl3-pp-dc-inet-1(config)#monitor session 1 source interface gigabitethernet0/25 both
swl3-pp-dc-inet-1(config)#monitor session 1 destination interface gigabitethernet0/26